Aronson Insurance Blog

Vulnerability in Internet Explorer (IE) All Versions

Due to the recent discovery of a security flaw found in all versions (6,8,9,10, and 11) of Internet Explorer, both the US and UK governments have published advisories suggesting that users either follow Microsoft’s mitigation instructions as described in Microsoft Security Advisory 2963983 or utilize a different browser until the vulnerability has been patched.  This unusual action should be noted as an indication of the severity and potential impact of this flaw that would allow an attacker to install malware on your PC that could be used to steal data or even take control of the computer.

Until Microsoft distributes a patch for this vulnerability, it is recommend that users employ an alternate browser (e.g., Google Chrome, Mozilla Firefox).  If you are required to use Internet Explorer please use your best judgment when clicking links, or visiting a site that you may not be familiar with.